Jenkins Security Advisory 2012-09-17

Skip to end of metadata
Go to start of metadata

This advisory announces security vulnerabilities that were found in Jenkins core and several plugins.

  1. The first vulnerability in Jenkins core allows unprivileged users to insert data into Jenkins master, which can lead to remote code execution. For this vulnerability to be exploited, the attacker must have an HTTP access to a Jenkins master, and he must have a read access to Jenkins.
  2. The second vulnerability in Jenkins core is a cross-site scripting vulnerability. This allows an attacker to craft an URL that points to Jenkins, and if a legitimate user clicks this link, and the attacker will be able to hijack the user session.
  3. The third vulnerability is a cross-site scripting vulnerability in the Violations plugin
  4. The fourth vulnerability is a cross-site scripting vulnerability in The Continuous Integration Game plugin

Several of these vulnerabilies were discovered by Avram Marius Gabriel.

Severity

The first vulnerability in the core is rated as critical, as it allows malicious users to execute arbitrary code on the server. The othe three XSS vulnerabilities are rated as high, as they allow malicious users to escalate privileges.

Fix

The following versions incorporate fixes to the vulnerabilities found in the Jenkins core.

  • Main line users should upgrade to Jenkins 1.482
  • LTS users should upgrade to 1.466.2

To patch vulnerabilities in the plugins, upgrade to the following versions. These plugins should be available in your Jenkins' plugin update center UI in up to a day.

  • Users of the Violations plugin should upgrade to 0.7.11 or later
  • Users of the CI game plugin should upgrade to 1.19 or later

Other resources

Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.