Jenkins : Installing Jenkins on OpenSolaris

Solaris / OpenIndiana packages have been discontinued

Due to declining usage and lack of Solaris developers in the community, it was decided in September 2014 to shut down the official Jenkins IPS repository.

This applies to all the distributions based on Image Package System (IPS), such as Solaris 11 and OpenIndiana.

First, you need one-time set-up to hook up Jenkins' IPS repository to your local system. The following two commands tell IPS to add http://ips.jenkins-ci.org/ with the nick name "jenkins" and update the local package list with this new repository. ('pfexec' is the Solaris speak for 'sudo'):

$ pfexec pkg set-authority -O http://ips.jenkins-ci.org/ips jenkins
$ pfexec pkg refresh

The IPS repository URL has four flavors. Use the one you like:

You can move from one repository to another by re-executing the "pkg set-authority" command with different URLs

You can then install Jenkins like this:

$ pfexec pkg install jenkins
$ pfexec /usr/sbin/svccfg import /var/svc/manifest/application/jenkins.xml

The first command installs Jenkins. The second command tells SMF to manage Jenkins as a service (this is apparently not needed in recent versions of Solaris, such as OpenIndiana, but it doesn't hurt to run it.) If you then go to http://localhost:8080/ you should see Jenkins running. Change /var/svc/manifest/application/jenkins.xml and run the svccfg import if you need to change the launch parameter, such as JVM size, HTTP port number, and so on.

To update to a newer Jenkins, you do:

$ pfexec pkg refresh
$ pfexec pkg install jenkins
$ pfexec svcadm restart jenkins